Sends are currently paused whilst we investigate a network issue
Incident Report for dotmailer
Resolved
The network connectivity issue has been resolved
Posted 9 months ago. Mar 12, 2017 - 11:02 GMT
Investigating
We have paused sends in region 1 (EU) whilst we investigate a network issue. More soon.
Posted 9 months ago. Mar 12, 2017 - 10:17 GMT