New Campaign creation issue - US
Incident Report for dotmailer
Resolved
We have made a configuration change to the affected servers, and campaign creation is now working normally again.
Posted 6 months ago. Nov 21, 2017 - 17:49 GMT
Investigating
US based customers may experience issues creating new campaigns via the dotmailer web application. The issue is being investigated and updates will follow when available.
Posted 6 months ago. Nov 21, 2017 - 17:17 GMT