Sending Delays
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 11, 2017 - 15:30 BST
Investigating
We are currently experiencing delays with sends in our our R1 Region.
Further updates will be provided when available.
Posted 2 months ago. Sep 11, 2017 - 15:04 BST