Split Test Campaigns
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 14, 2017 - 09:30 BST
Investigating
There is currently an issue with Split Test Campaigns. The issue is being investigated and an update will be provided in due course.
Posted 2 months ago. Jul 14, 2017 - 09:12 BST