Contact Import Delays
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 03, 2017 - 12:30 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 17 days ago. Oct 03, 2017 - 11:37 BST
Investigating
We are currently experiencing delays with contact imports in Europe. This is currently under investigation. Further updates will provided when available.
Posted 17 days ago. Oct 03, 2017 - 10:37 BST