Intermittent issues logging into dotmailer
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 14 days ago. Mar 10, 2017 - 09:48 GMT
Monitoring
Users should now be able to log into their dotmailer accounts as normal.

However, we will continue to monitor the situation.
Posted 14 days ago. Mar 10, 2017 - 09:39 GMT
Investigating
Some customers may face intermittent issues logging into their dotmailer account.

We are currently looking into the issue and will update you once we have some more information.
Posted 14 days ago. Mar 10, 2017 - 09:06 GMT