Intermittent access to dotMailer portal
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 29, 2017 - 12:20 BST
Investigating
We are investigating a problem with intermittent or slow access to the dotMailer application portal in Europe region.
Posted 21 days ago. Sep 29, 2017 - 12:14 BST