We are currently investigating problems with email sends in our Europe region (R1)
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 10, 2017 - 05:08 BST
Investigating
We are currently investigating this issue.
Posted 2 months ago. Oct 10, 2017 - 04:45 BST