Access to Survey site
Incident Report for dotmailer
Resolved
The issue has now been resolved.
Posted 3 months ago. Jun 05, 2017 - 16:21 BST
Identified
The issue has been identified. Our engineering teams are currently working on a fix.
Further updates will follow.
Posted 3 months ago. Jun 05, 2017 - 15:58 BST
Investigating
There is currently an issue with accessing our survey site.
Updates to follow in due course.
Posted 3 months ago. Jun 05, 2017 - 15:47 BST