Delays with Reporting Data in our R3 Region
Incident Report for dotmailer
Resolved
This incident has been resolved.
Posted 12 days ago. Aug 11, 2017 - 08:50 BST
Monitoring
The issue has now been resolved. However, we will monitor the situation over the next few hours.
Posted 12 days ago. Aug 11, 2017 - 06:50 BST
Investigating
Some customers may face delays with reporting data in our R3 region.

Our engineers are currently looking into the issue.
Posted 12 days ago. Aug 11, 2017 - 06:31 BST