Issues loading images on our corporate website
Incident Report for dotmailer
Resolved
Our corporate website is now operating as normal.
Posted 2 months ago. Oct 04, 2017 - 17:13 BST
Identified
Browsers may experience some images not loading on our corporate website, while we solve an issue with our image storage.

This does not affect the dotmailer platform or campaign imagery.
Posted 2 months ago. Oct 04, 2017 - 11:55 BST