Europe - Reporting delays
Incident Report for dotmailer
Resolved
This incident has now been resolved and reporting is back to normal
Posted 3 months ago. Apr 11, 2017 - 19:12 BST
Identified
The issue has been identified and fix is currently being worked on.
Posted 3 months ago. Apr 11, 2017 - 17:22 BST
Investigating
Some customers may experience delays in reporting data
The root cause of the issue is being investigated
A further update will be provided in 30 minutes
Posted 3 months ago. Apr 11, 2017 - 16:38 BST